Follow

Links to ePIsource Medical (Corex)

 

For ePIsource Medical (Corex) please click on relevant the link below:

Smartclient
Webclient

ePIsource Medical Smartclient requires Java to be installed on your machine. Please do not install any higher than version 6 of Java. Please click here for the latest version of Java 6 for Windows.

Apple supplies their own version of Java. Please click here for the latest version of Java 6 for Mac. All versions of our software are compatible with OSX Mavericks.

For Webclient, we recommend that you use a new modern browser such as Google Chrome, Firefox or Safari. 

Was this article helpful?
2 out of 3 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk